pdqn.net
当前位置:首页 >> EClipsE安装显示需要jDk1.7或者更高版本,但是电脑已经安装jDk1.8。必须是jDk1.7... >>

EClipsE安装显示需要jDk1.7或者更高版本,但是电脑已经安装jDk1.8。必须是jDk1.7...

Eclipse在安装的时候,会首先检查当前电脑是否正确安装适合版本的JDK环境,如果没有正确安装或安装的版本过低,出现图中提示信息.1. 第一种情况:虽然已经安装JDK1.8,可能环境变量配置存在问题,Eclipse检测不通过,还有可能是安装版的JDK1.8,重复配置JDK环境路径,解决办法:删除手动配置的环境路径2. 第二种情况:压缩版的JDK1.8需要手动配置高级环境变量,配置过程同时添加JRE路径3. 上述两种方法无法解决,将已配置的JDK1.8环境变量或安装版的JDK1.8卸载后,重新下载上图提示下载版本安装后,重装Eclipse(卸载后,记得重启电脑)

这个应该是写死在eclipse里面的,因为我本机jdk是1.6的但是eclipse的编译level可以选择1.7这明显是不合理的,所以我怀疑这个编译level是写死在eclipse中或者是某个配置文件中的,你可以去下载下最新的eclipse试试看有没有1.8的选项

jdk就含有jre,这个不关事的,应该是环境配置错了吧JAVA_HOME C:\Program Files\Java\jdk1.8.0_40PATH %JAVA_HOME%\bin;

大意是,你项目描述使用的编译级别是jdk1.4,但是你工作空间默认的编译级别是jdk5.0.这个只是一个警告,不是错误,也不会影响你的项目.去除这个警告的方法有2:1、去掉项目j2ee1.4的环境,改用j2ee5.0的环境.2、项目名称上右键,选择java compiler,手工改变compiler compliance level为1.4

这个不用统一,但是JDK,eclipse,tomcat的位数必须一致

1.ecilpse自带jdk的 其实你安装完成之后默认使用的就是自带的jdk 自己另外安装jdk是方便使用 在控制台下~~~2.比如你安装的jdk的目录在c:\program files\java下有两个文件夹jre6 和jdk1.6.0_10,则环境变量设置如下:path: 在原先的值后面用分

在配置文件中把java指向不通的java_home下面就可以的以win7下的android studio为例C:\Users\用户名\.AndroidStudio1.8\config\options\jdk.table.xml

多数编辑器或自带jdk,如果你用的编辑器的话你需要修改默认的jdk版本,将你自己安装的jdk引用到默认的jdk下

是不是因为JDK和eclipse不兼容啊,你换成1.6的JDK试试

eclipse的版本限制,你换一个高版本的eclipse就可以了.

相关文档
网站首页 | 网站地图
All rights reserved Powered by www.pdqn.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com